Radium 6.7.75 released

Post Reply
kjetil
Site Admin
Posts: 492
Joined: 20 Jul 2017 20:45

Radium 6.7.75 released

Post by kjetil » 22 Jan 2021 13:36

Most work this time has been spent working on converting editor automation to the new data structure. This should both cause less CPU usage and make it possible to hear changes immediately while playing. Converting to the new data structure is also necessary for other things in the future, such as replacing OpenGL with Vulkan. However, this work is not quite finished yet, so it's not included in this release.

This release however contains various important bug fixes such as fixing garbled editor font sometimes happening on Windows, crashes sometimes happening when loading soundfonts, and audio glitches possibly happening when modifying the audio graph.

Changes 6.7.72 -> 6.7.74:
  • Audio: Disable lots of debug outputs to the
    terminal when modifying the audio graph. (Debug
    and Release mode were switched.) This also might
    fix some audio glitches.
  • Windows: Fix garbled font rendering sometimes
    happening in the editor. Bug introduced in v6.7.69.
    (The problem existed before 6.7.69 too, but not
    as often).
  • Internal: Fix a memory corruption introduced in
    v6.6.77. The bug probably only manifested in
    debug builds though, and not in any releases.
  • Internal: Fix semi-rare memory leak when showing a
    system error message.
  • NSM: Fix error message popping up after startup.
  • Editor: Fix transposing MIDI 7 bit automation when
    pressing Left Alt + U or Left Alt + D and the
    cursor was placed inside an fxtext subtrack.
  • MIDI: Fix crash when starting to play in the middle
    of a song at a position where there is MIDI
    automation in the editor.
  • Build: Update libgig from 3.3.0 to 4.2.0. Fixes
    crash when loading some soundfonts.



kjetil
Site Admin
Posts: 492
Joined: 20 Jul 2017 20:45

Re: Radium 6.7.75 released

Post by kjetil » 27 Jan 2021 18:52

Radium 6.7.76 released. Various minor fixes.

Changes 6.7.75 -> 6.7.76:
  • Windows: Fix import MOD when the username contains
    non-ascii characters.
  • Windows: Fix displaying filename with non-ascii
    characters in the progress window when importing
    MOD files.
  • Audio: Don't show error about not being able to
    open soundfont file when failed loading a sound
    file (we already show a general message about
    not being able to open the file).
  • Sequencer: Fix error messages popping up after
    pressing the Esc key when prompted to manually
    write new path in the file browser.
  • Windows: Fix displaying paths with non-ascii
    characters in the file browser in the right-side
    sequencer tabs.
  • Editor: Add options to set high priority for the
    OpenGL render thread and the OpenGL drawer thread.
  • Preferences: Remove the OpenGL "Safe mode" option.
  • Preferences: Move the "Vertical blank" OpenGL
    option into an "advanced" tab (since you normally
    don't want to touch this option).
  • Preferences: Move the "OpenGL" tab to the right of
    the "GUI" tab.
  • API: Add "message_is_base64" option to
    openProgressWindow

Post Reply